Phone Systems Issue Friday 29th October 2021 15:00:00


FIXED: Oct/29/2021 03:25 PM EST

The phone lines are working normally again.

Thank you for your patience and understanding in this matter.


INVESTIGATING Oct/29/2021 03:00 PM EST

We have identified an issue with our voice support phone lines. You may not be able to contact us via phone.

This is being investigated, and we will update this status page periodically until resolved.

We're sorry for the inconvenience. You can still contact support via the Toll Free system, our ticket system, by email, and via LiveChat support at our website (https://www.hostpapa.com).