Basic/Advanced Email Access Issues Friday 23rd August 2019 05:25:00


Update (10:00am EST):

The Webmail, IMAP and POP issues we were experiencing on our Basic/Advanced servers are now resolved. Service has been restored.

Thank you for your patience as we worked to resolve this.


Update (9:15am EST):

The issue has been identified, and a fix is being implemented. We are seeing progress with our current fixes. We will continue to post an update as they occur.


Update (8:00am EST):

Our team is still investigated the issue. We determined that only users from Europe and South Africa are currently affected.

Further updates will be provided as they become available.


5:25am EST:

We are investigating an issue preventing some users on Basic and Advanced email service from logging into Webmail, IMAP and POP. Our operations team has been engaged.

We will provide an update once we have additional information.