Phone Support System issue Tuesday 8th February 2022 12:26:00


FIXED FEB/08/2022 4:00 pm

The issue has been resolved. Thank you for the patience.


INVESTIGATING FEB/08/2022 12:00 PM

We have identified an issue with our voice support phone lines that are affecting incoming and outgoing calls. You may not be able to contact us via phone.

This is being investigated, and we will update this status page periodically until resolved.

We're sorry for the inconvenience. You can still contact support via our ticket system, by email, and via LiveChat support at our website (https://www.hostpapa.com).