Website Builder Publishing Issue Tuesday 15th February 2022 14:41:00


FIXED: Feb/16/2022 03:25 AM EST

The issue has been resolved and the Website Builder is operating normally again at this time.

Should you continue to have any issues, please contact our support team through Phone, Email, and Live Chat: https://www.hostpapa.com/about-hostpapa/contact/.


INVESTIGATING: Feb/16/2022 02:30 PM EST

There is a known issue with the Website Builder that our technicians are investigating at this time to resolve it as soon as possible.

Some users may receive an error when attempting to Publish from Website Builder.

We're sorry for any inconvenience this may cause. We will update this page with further updates on the issue. Thank you for your patience and cooperation.