Domain registration issue Thursday 24th February 2022 12:11:00


FIXED: Feb/24/2022 01:10 PM EST

The issue with the Domain Registration form is already fixed.

Thank you again for your patience.


IDENTIFIED DOMAIN REGISTRATION FORM: Feb/24/2022 12:00 PM EST

We identified an issue with the Domain registration form which seems to be broken.

Our developers are already working on a fix. More updates will be informed here.

Thanks for your cooperation and we are sorry for any inconvenience.