Servers XEN124 and KVM124 under maintenance Wednesday 30th March 2022 11:57:00


FIXED: MAR/30/2022 12:20 PM EST

The issue has been resolved and the servers (XEN124 and KVM124) are operating as expected again.

Should you have any issues, please, do not hesitate to contact us via LiveChat, Phone or Email/Support Ticket.

Thanks for your patience in this subject.


IDENTIFIED: MAR/30/2022 11:55 AM EST

Servers: XEN124 and KVM124 are experiencing an issue that may affect some customers on those servers.

This has been identified by our server health team and they are working to resolve the issue as soon as possible.

We count on your understanding and comprehension. As soon as it's completed, we'll update it here. Thanks!