FIXED: Apr/22/2022 10:55 AM EST
This incident with LiveChat has been resolved.
If you encounter any issues on your end, don't hesitate to reach us by phone or email to let us know.
Thanks for your patience and understanding.
MONITORING: Apr/22/2022 10:20 AM EST
Fix has been implemented and the situation is stabilizing. We'll keep monitoring the performance.
INVESTIGATING: Apr/22/2022 9:25 AM EST
Our LiveChat system is currently experiencing some issues and you may not be able to use it at this time. We're investigating this currently and further updates will be provided here.
You can still reach us by phone or support ticket/email. Thank you for your patience and cooperation.