Payment issues on AU brand Tuesday 7th June 2022 05:00:00


FIXED: June 09th 2022 07:00 AM EST

A fix for this has now been deployed and our testing shows that credit card payment in AU is now working normally, but we are watching the issue closely to ensure resolution. Please reach out to our Support via Live Chat, Phone or Email, if you are still encountering issues when making credit card payment.


INVESTIGATING: June 07th 2022 05:00 AM EST

We're currently experiencing an issue with processing credit card transactions on AU brand. We're currently looking into fixing it as soon as possible. Meanwhile, orders can be placed using a PayPal account and renewal invoices can also be manually paid via PayPal. If you have a renewal invoice due in the next 24 hours, kindly reach out to [email protected]. We apologize for any inconvenience and delay.