Website Builder Access Issue Tuesday 14th June 2022 07:25:00


FIXED: 14/Jun/2022 10:25 AM EST

Website Builder access should be up and running now. Please check if you are able to locate and access your account on your end and let us know if further help is needed.

Our support is here to help you 24/7 via chat, phone or email. Thanks for your patience and understanding.


INVESTIGATING: 14/Jun/2022 07:25 AM EST

There is a known issue with the Website Builder that our technicians are investigating at this time to resolve it as soon as possible.

Some users may receive an error or have difficulty when trying to access it from the Hostpapa Dashboard.

We're sorry for any inconvenience this may cause. We will update this page with further updates on the issue. Thank you for your patience and cooperation.