Basic/Advanced Email Issue Friday 22nd July 2022 03:25:00


FIXED: Jul/22/2021 04:35 AM EST

Our engineering team has fixed the issue. If you are still experiencing issues with your emails, please contact our Support team through Live Chat, Phone, or Email [email protected]

Thank you for your patience in this matter.


INVESTIGATING: Jul/22/2021 03:25 AM EST

We are currently experiencing login issues with HostPapa Basic/Advanced email accounts.

We are investigating this at this time, and will provide updates as they are available.

Thank you for your patience.