Basic/Advanced Email Issues Thursday 28th July 2022 17:12:00


FIXED: JUL/28/2022 05:35 PM EST

Our engineering team has fixed the issue. If you are still experiencing issues with your emails, please contact our Support team through Live Chat, Phone, or Email [email protected]

Thank you for your patience in this matter.


INVESTIGATING: JUL/28/2022 - 5:10 PM EST

Some users may experience issues with inbound and outbound mail on PapaMail (Basic/Advanced Email). Our engineering team is investigating the issue.

We will provide an update once we have additional information. Thanks for your understanding.