Basic/Advanced Email Issues Thursday 18th August 2022 09:00:00


MONITORING: AUG/18/2022 - 6:25 PM EST

At 4:00 AM EST on August 18, 2022, we began experiencing service interruptions on our hosted email service. Mailbox users experienced errors or timeouts when attempting to access their mailboxes or send emails. Some also experienced delays in receiving emails. Our email service is now stable and functioning normally. We want to confirm that:

There has been no email loss!! Outbound emails that had failed to send during this time have now been successfully sent. We are currently working through a queue of backlogged inbound emails, which we expect to have cleared in the next few hours.

Moving forward, since the issue began, our engineering team has been focused on restoring functionality to expected levels. Now that the service is operational, we are investigating the root cause. Full details will be provided as soon as possible.

We sincerely apologize for the upset that this incident has caused you and your customers. We failed to deliver the level of service you deserve, and we are committed to doing better.


MONITORING: AUG/18/2022 - 5:20 PM EST

Cluster A IMAP, outbound, webmail and MAC are back online.

Inbound email is going to be seeing delays as backlog from this morning is still processing. Our engineers will be monitoring the situation.


UPDATE - STILL INVESTIGATING: AUG/18/2022 - 4:30 PM EST

We are currently experiencing intermittent service interruptions of our hosted email service. We are actively working to resolve this issue. We sincerely apologize for the upset to both you and your customers.

What’s happening: At 4:00 AM EST, our Specialists found out an intermittent failure to access mailboxes on our Papamail service. As a result, users experienced and continue to experience errors or timeouts when attempting to access their mailbox or send emails. Some are also experiencing delays in receiving emails.

You may continue to experience delays in receiving emails, as well as failures or errors when logging in or sending emails.

However, there will be no email loss:

Why did this happen? At this time, we’re focusing all our resources on restoring functionality to expected levels. Full details will be provided with you as soon as possible.

What is the path toward resolution? Currently, we are focused on performing discrete component diagnostics. As components are reconfigured and added back to the platform, service will gradually return to normal levels.

Right now, we cannot offer an expected time of resolution. That said, our troubleshooting efforts have provided valuable insights, and we are progressing toward a full recovery.

Once again, we're really sorry and apologize for all the inconvenience caused on your side. Thanks for the patience so far!


NEW UPDATE - INVESTIGATING: AUG/18/2022 - 3:20 PM EST

Our engineers continue to work toward mitigating impact and restoring services.

We will continue to provide updates as they come. IMAP/Webmail connection and sending/receiving is still intermittent at this time.


UPDATE - INVESTIGATING: AUG/18/2022 - 12:20 PM EST

At this time we have seen some improvements overall but are still experiencing intermittent issues with a subset of users being able to send/receive and login via IMAP/webmail.

Our team continues to work towards to restore services. We appreciate your continued patience.


INVESTIGATING: AUG/18/2022 - 9:00 AM EST

Some users may experience issues with inbound and outbound mail on PapaMail (Basic/Advanced Email). Our engineering team is investigating the issue.

We will provide an update once we have additional information. Thanks for your understanding.