FIXED: Aug/22/2021 09:35 AM EST
Our engineering team has fixed the issue. If you are still experiencing issues with your emails, please contact our Support team through Live Chat, Phone, or Email [email protected]
Thank you for your patience in this matter.
INVESTIGATING: Aug/22/2021 09:10 AM EST
We are currently experiencing login issues with HostPapa Basic/Advanced email accounts.
We are investigating this at this time, and will provide updates as they are available.
Thank you for your patience.