Connectivity Issue on server r130 Tuesday 15th October 2019 19:00:00


FIXED (12:11 AM EST) - This incident has been resolved and server connectivity has been stabilized.

MONITORING (09:35 PM EST) - We have successfully identified the problem affecting r130. A fix has been implemented, and we're monitoring the results.

INVESTIGATING - Our Server Health team is investigating an issue with our server r130. During this time, you may experience downtime with Emails and Website. Similar issues are not detected on any other servers in our fleet at the moment.

We apologize for the inconvenience and will share an update once we have more information.