Papamail Issues Wednesday 28th September 2022 11:12:00


INVESTIGATING: Sep/28/2022 11:00 AM EDT

We are currently experiencing inbound mail delays on Cluster A. Our engineering team is investigating the issue.

Both Basic and Advanced email services are affected by this.

We appreciate your patience and understanding.

FIXED: Sep Sep/28/2022 1:30 PM EDT

The traffic has subsided on its own as per the engineering team and we are no longer experiencing any inbound delays on Cluster A.

We apologize for any inconvenience and if you have encoutered any issue after this time, please, reach our live support via chat, ticket or voice. Thanks for you comprehension!