HP Dashboard and Ticketing System - Maintenance Wednesday 23rd November 2022 05:00:00


UPDATE: Nov/23/2022 05:45 AM EST

The dashboard and ticketing systems have been successfully updated, some remaining issues are being investigated, and updates will follow once they are resolved.

Thank you for your understanding.


INVESTIGATING Nov/23/2022 05:00 AM EST

We are currently performing an upgrade on the ticketing and dashboard systems, the estimated downtime is around 1 hour.

More updates will be posted as they are available. Thank you for your understanding.