HP Dashboard and Ticketing System - Maintenance Friday 25th November 2022 11:34:06


INVESTIGATING Nov/25/2022 11:30 AM EST

We are currently performing an upgrade on the ticketing and dashboard systems, the estimated downtime is around 1 hour.

More updates will be posted as they are available. Thank you for your understanding.

UPDATE: Nov/25/2022 11:45 AM EST

The dashboard and ticketing systems have been successfully updated, and working correctly once again.

Thank you for your understanding.