HP Dashboard and Ticketing System - Maintenance Tuesday 29th November 2022 04:05:00


Fixed: Nov/29/2022 05:20 AM EST

The dashboard and ticketing systems have been successfully fixed, should you have issues make sure to contact our support team via LiveChat or Phone. You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.

Thank you for your understanding.


INVESTIGATING Nov/29/2022 04:05 AM EST

We are currently having emergency maintenance on the ticketing and dashboard systems, downtime is expected during this time.

More updates will be posted as they are available. Thank you for your understanding.