North American toll-free line not working Thursday 8th December 2022 12:10:46


INVESTIGATING DEC/8/2022 12:00 PM

We are aware that our North American toll-free number 1-888-959-7272 is currently not working correctly. We are working with our carrier to restore service. In the meantime, we ask North American customers to please use 905-315-3455 to contact us. .

We're sorry for the inconvenience.

You can also contact us via our ticket system, by email and via LiveChat support at our website (https://www.hostpapa.com).

FIXED: DECEMBER/08/2022 4:30 PM EST

The issue we encountered with US phone number is fixed at the moment and the toll-free line is back.

We apologize for any inconvenience and we're at your disposal 24/7 via chat, phone and email. Thanks for your patience!