North American toll-free line not working Wednesday 14th December 2022 18:02:17


INVESTIGATING DEC/14/2022 6:00 PM

We are aware that our North American toll-free number 1-888-959-7272 is currently not working correctly. We are checking with our carrier to restore service. In the meantime, we ask North American customers to please use 905-315-3455 to contact us.

We're sorry for the inconvenience.

You can also contact us via our ticket system, by email and via LiveChat support at our website (https://www.hostpapa.com).

FIXED: December/21/2022 - 2:00PM

The issue presented with the North-American line is fixed and you should be able to call us without any problem to our toll-free line at the moment.

If you encounter any issue, please, let us know! You can reach us by alternate phone number, chat or email.

Thanks for your patience and understanding.