Dashboard login and Ticket system issues Friday 6th January 2023 00:35:00


Fixed: Jan/06/2023 04:20 AM EST

The dashboard and ticketing systems have been successfully fixed, should you have issues make sure to contact our support team via LiveChat or Phone. You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.

Thank you for your understanding.


UPDATE: Jan/06/2023 03:55 AM EST

The current issue with the Dashboard and Ticketing systems are still being looked into it, we are working towards fixing this, we appreciate your patience during this time.


INVESTIGATING: Jan/06/2023 12:35 AM EST

We are currently having emergency maintenance on the ticketing and dashboard systems, downtime is expected during this time.

More updates will be posted as they are available. We sincerely apologize for the inconvenience that this has caused.

Thank you for your understanding.