North American toll-free line not working Wednesday 11th January 2023 11:07:00


UPDATE: JAN/24/2023 9:00 AM

We are still investigating the current issues with our carrier to restore service. In the meantime, we ask North American customers to please use +1-905-315-3455 to contact us.

We're sorry for the inconvenience.

You can also contact us via our ticket system, by email and via LiveChat support at our website (https://www.hostpapa.com).


INVESTIGATING JAN/11/2023 11:00 AM

We are aware that our North American toll-free number 1-888-959-7272 is currently not working correctly. We are checking with our carrier to restore service. In the meantime, we ask North American customers to please use +1-905-315-3455 to contact us.

We're sorry for the inconvenience.

You can also contact us via our ticket system, by email and via LiveChat support at our website (https://www.hostpapa.com).

FIXED: Feb/24/2023 - 11:00 AM EST

We are glad to inform you that after a period of instability in our toll-free North American line, we could find the issue and a permanent resolution.

If you encounter any problem while reaching us through this number, just let us know.

Thanks for your patience and understanding during this period.