Basic / Advanced Email - webmail degradation Saturday 2nd November 2019 20:01:00


Update: The issue is now resolved. Thank you for your patience!


We are currently investigating an issue with our Basic / Advanced email services that affects Webmail login. This affects only some users from UK location who might experience intermittent issues with the login to the webmail interface.

Updates will be posted as soon as the issue will be resolved. We are sorry for any inconvenience caused.