Papamail - Email Accessibility Issue Thursday 9th March 2023 10:30:07


INVESTIGATING: Mar/09/2023 10:20 AM EST

We are investigating an issue preventing users on Cluster A from logging into Webmail. Our Engineering team is already working on the resolution as soon as possible.

We sincerely apologize for the inconvenience caused. We will provide an update once we have additional information.

RESOLVED: Mar/09/2023 10:40 AM EST

This incident has been resolved. Webmail services have now fully recovered.

We apologize again for the inconvenience and you can contact us if you encounter any issues. Thanks for your understanding.