Multiple Dedicated Servers - Emergency Maintenance Monday 10th April 2023 20:30:00


UPDATE: April/11/2023 - 8:15 AM EST

We are still working on a permanent fix for the affected dedicated servers from Quadranet, services located on these servers may be affected and become inaccessible.

We sincerely apologize for the inconvenience caused.

Further updates will be posted once available. Thank you for your patience.


EMERGENCY MAINTENANCE: April/10/2023 - 8:30 PM EST

We will be having emergency maintenance performed on multiple servers from Quadranet and services located on these servers may be affected and become inaccessible.

We sincerely apologize for the inconvenience caused.

Further updates will be posted once available. Thank you for your patience.

COMPLETED: April/11/2023 - 1:35 PM EDT

The maintenance has been completed and all servers are operating normally again.

Should you continue to have any issues, please don't hesitate to get in touch with our support team via LiveChat, Phone, or Email/Support Ticket. You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.