Payment Processor - Credit Card Payment Issue Wednesday 12th April 2023 06:40:00


FIXED: Apr/12/2023 08:15 AM EST

A fix for this has now been deployed and our testing shows that credit card payment is now working normally, but we are watching the issue closely to ensure resolution. Please reach out to our Support via Live Chat, Phone or Email, if you are still encountering issues when making credit card payments.


INVESTIGATING: Apr/12/2023 06:40 AM EST

We are currently experiencing some issues with our payment processor preventing some orders to complete. Our team is currently investigating the problem and updates will be posted here regarding the issue.

We're sorry for the inconvenience this is causing at this time and are working to correct it as soon as possible.