Multiple Servers - Emergency Maintenance Friday 14th April 2023 01:30:00


COMPLETED: April/14/2023 - 5:45 AM EST

The emergency maintenance has been completed for the aforementioned servers.

Should you continue to have any issues, please don't hesitate to get in touch with our support team via LiveChat, Phone, or Email/Support Ticket. You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.

UPDATE: April/14/2023 - 5:00 AM EST

The maintenance on server WS06 and WS05 has been completed. The WS08 server is on going.

Further updates will be posted once available. Thank you for your patience.


UPDATE: April/14/2023 - 4:00 AM EST

The maintenance on server WS07 has been completed. The WS05, WS06 and WS08 server is on going.

Further updates will be posted once available. Thank you for your patience.


EMERGENCY MAINTENANCE: Apr/14/2023 01:30 AM EST

We will be having emergency maintenance performed on multiple servers and as such services located on this server may be affected and become inaccessible.

ws05.servername.online, ws06.servername.online,
ws07.servername.online, and
ws08.servername.online

We sincerely apologize for any inconvenience caused.

We will post updates once available. Thank you for your patience.