R128 - Emergency Maintenance Thursday 20th April 2023 16:46:00


COMPLETED: Apr/21/2023 05:45 AM EST

The emergency maintenance has been completed and R128 is operating normally again.

Should you continue to have any issues, please don't hesitate to get in touch with our support team via LiveChat, Phone, or Email/Support Ticket. You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.


UPDATE: Apr/21/2023 12:00 AM EDT

Our System Admins are continuously working to apply the fix to stabilize the load on the server.

We will post updates as soon as it is made available.

We sincerely apologize for the inconvenience caused.

========================================================================

UPDATE: Apr/20/2023 7:00 PM EDT

Our System Admins are still working on the issue with the server load.

We will post further updates as they are made available.

========================================================================

EMERGENCY MAINTENANCE: Apr/20/2023 4:40 PM EST

R128 is having emergency maintenance performed on it, and as such services located on this server may be affected and become inaccessible.

We sincerely apologize for any inconvenience caused.

We will post updates once available. Thank you for your patience.