Hostpapa Status Page

Some systems are experiencing issues.

16 hours ago ยท
Identified

UPDATE: AUG/12/2026 - 1:43 AM EST

Please be advised that the restoration is still ongoing. Our engineering teams are continuing to work actively on restoration efforts, but full resolution is taking longer than initially anticipated.

We understand the severe impact this disruption has on your operations, and we really apologize for the ongoing inconvenience and frustration this has caused.

A final status update will be published immediately upon complete resolution.

We sincerely appreciate your continued patience and cooperation during this time.

=========================================================================

UPDATE: AUG/11/2026 - 7:55 PM EST

Please be advised that service restoration is currently underway. Our engineering team is actively managing the situation to ensure complete recovery.

A final status update will be published immediately upon resolution.

We sincerely appreciate your continued patience and cooperation during this time.

=========================================================================

We are currently addressing an issue that may affect a small number of customers using our DNS services without an active hosting plan. Some customers may experience temporary issues accessing their domain-related services, including email. Our team is actively working to restore normal service as quickly as possible. Customers with an active HostPapa hosting plan are not expected to be affected. We will share further updates if needed.

Incident UUID 8c480b53-7b6c-4d5a-a124-bd2265935e9a