Papamail Issues Detected Monday 1st May 2023 17:07:00


FIXED: May/02/2023 7:15 PM EDT

As of the time of this update, normal service operations have been restored, all users are now able to log in without issue, and all new send requests are being processed as expected. The remaining backlog of inbound email requests may take up to a couple of hours to clear.

Having the main issue cleared, we will now mark this incident as resolved.

We sincerely apologize for the impact this service interruption has had.

Should you continue to have any issues, please don't hesitate to get in touch with our support team via LiveChat, Phone, or Email/Support Ticket. You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.

============================================================================================

UPDATE: May/02/2023 3:10 PM EST

Our system is now actively processing backlogged email requests. Users may continue to experience intermittent login issues and delays in sending and receiving emails over the next few hours. By 7 PM ET, we expect most of the backlog to be cleared and for our email service to function normally.

============================================================================================

UPDATE: May/02/2023 12:15 PM EST

Users are still experiencing login issues as well as delays and failures to send and receive emails. We’re continuing the recovery process to restore service.

============================================================================================

UPDATE: May/02/2023 10:40 AM EST

On May 1, 2023, at approximately 5 PM EST, our system alerted us to an attempted large-scale DDoS attack on our Dedicated Email Service. We safely mitigated this attack.

However, the large volume of requests caused an interruption to our authentication service. We are now gradually ramping up our email service by our recovery procedure. No data has been or will be lost.

More updates will follow as they happen.

============================================================================================

UPDATE: May/02/2023 10:00 AM EST

Restoration efforts are underway. There will be no data or email loss. Both inbound and outbound emails will be delivered gradually upon full restoration of the service.

============================================================================================

UPDATE: May/02/2023 06:00 AM EST

Our teams are still working hard to resolve the Basic/Advanced Email issues. We will continue to update you with any new information or resolution as soon as possible. We appreciate your patience.

============================================================================================

UPDATE: May/02/2023 03:25 AM EST

Our Engineering team is still working on a fix to this problem.

We are very sorry for the inconvenience this has caused.

Further updates will be posted as soon as made available.

============================================================================================

UPDATE: May/02/2023 12:00 AM EST

Our Engineering team is continuously working hard to fix the problem.

We are very sorry for the inconvenience this has caused.

Further updates will be posted as soon as made available.

============================================================================================

UPDATE: May/01/2023 10:00 PM EST

Our Engineering team is continuously working to resolve the issue as soon as possible.

We appreciate your understanding and patience in this matter.

Further updates will be posted as soon as made available.

============================================================================================

UPDATE: May/01/2023 7:00 PM EST

Our Engineering team is still working to resolve the issue as quickly as possible.

Further updates will be posted as soon as made available.

============================================================================================

UPDATE: May/01/2023 6:00 PM EST

Our Engineering team has identified the problem and working on a fix.

Further updates will be posted as soon as made available.

============================================================================================

INVESTIGATING - May/01/2023 - 5:00 PM EST

Our engineering team is investigating an issue with Papamail. Clients will have difficulties logging into the webmail, as well as sending/receiving emails.

We sincerely apologize for the inconvenience caused.

We will provide an update once we have additional information.