LiveChat System is experiencing issues Wednesday 3rd May 2023 11:27:27


INVESTIGATING: May/03/2023 - 11:25 AM EDT

Our LiveChat system is currently experiencing some issues and you may not be able to use it properly at this time. We're investigating this currently and further updates will be provided here.

You can still reach us by phone or support ticket/email. Thank you for your patience and cooperation.

FIXED: May/03/2023 - 12:35 PM EDT

A fix has been implemented and this case can now be closed.

Thanks for your comprehension.