VPS/Ded - Acronis not working properly Thursday 8th June 2023 17:52:39


INVESTIGATING: Jun/08/2023 - 5:45 PM EDT

Our server health team is currently investigating an issue related to Acronis not working properly. It should only affect VPS/Dedi customers paying for backups.

We will provide further updates via this status page as they are made available.

Thank you for your patience and understanding while it's being resolved. We sincerely apologize for the inconvenience caused.

FIXED: Jun/08/2023 - 9:15 PM EDT

Our Server Admins have fixed the issue and VPS/Ded accounts must now work as expected.

If you encounter any issues, please contact our Support team through Live Chat, Phone, or Email at [email protected].

Thank you for being so patient in this matter.