Papamail - Emergency Maintenance Monday 12th June 2023 12:15:41


EMERGENCY MAINTENANCE: June/12/2023 - 12:15 PM EST/EDT

We will be undergoing planned system maintenance on our Papamail servers which will primarily address system improvements.

During this time, you may see longer response times than usual, but we do not expect any service impact or downtime.

The scheduled maintenance will take place from 12:30 PM to 2:30 PM EST.

We will post further updates once available.

COMPLETED: June/12/2023 - 2:30 PM EST/EDT

The scheduled maintenance has been completed.

We appreciate your patience and understanding during this process.

IN PROGRESS: June/12/2023 - 12:30 PM EST/EDT

Scheduled maintenance is currently in progress. We will provide updates as necessary.