Papamail Advanced/Basic Issues Detected Thursday 20th July 2023 04:30:00


FIXED: July/20/2023 - 4:50 AM EST

As of the time of this update, normal service operations have been restored, all users are now able to log in without issue, and all new send requests are being processed as expected.

Having the main issue cleared, we will now mark this incident as resolved.

We sincerely apologize for the impact this service interruption has had.

Should you continue to have any issues, please don't hesitate to get in touch with our support team via LiveChat, Phone, or Email/Support Ticket. You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.

============================================================================================

INVESTIGATING - July/20/2023 - 4:30 AM EST

We are currently experiencing an incident that is impacting Papamail Advanced/Basic, (IMAP, POP, Webmail). We have been made aware that a small amount of users on Papamail may have issues logging in to their email. Our Hosted Email engineering are investigating and we will update you shortly