Dashboard Login and Ticket System Issues Tuesday 1st August 2023 06:40:00


RESOLVED: August/01/2023 - 07:00 AM EST

The emergency maintenance has been completed, the Dashboard and ticketing system are back online. We are still monitoring to ensure stability.

Thank you for your patience.


INVESTIGATING: Aug/01/2023 06:40 AM EST

We are currently having emergency maintenance on the ticketing and dashboard systems, downtime is expected during this time.

More updates will be posted as they are available. We sincerely apologize for the inconvenience that this has caused.

Thank you for your understanding.