WS09 - EMERGENCY MAINTENANCE Sunday 10th September 2023 22:00:00


COMPLETED: Sep/11/2023 - 08:30 AM EST

The emergency maintenance has been completed and WS09 is back up and running. There are updates being performed which should be completed in about 1 hour.

Should you continue to have any issues, please don't hesitate to get in touch with our support team via LiveChat, Phone, or Email/Support Ticket. You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.


UPDATE: Sep/11/2023 - 03:00 AM EST

WS09 is still under emergency maintenance, we will post updates as soon as we have a permanent fix, services located on this server may be affected and become inaccessible.

We sincerely apologize for any inconvenience caused.

Thank you for your patience.


EMERGENCY MAINTENANCE: Sep/10/2023 - 10:20 PM EST

WS09 is having emergency maintenance performed on it, and as such services located on this server may be affected and become inaccessible.

We sincerely apologize for any inconvenience caused.

We will post updates once available. Thank you for your patience.